Mail Konfiguration

Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

From: Mathias Waack (mathias_at_mufasa.informatik.uni-mannheim.de)
Date: 14. Oct 1999


Hi all,

ich habe bei mir ein Problem mit der Mail Konfiguration. Auf
meinem Rechner gibt es mehrer lokale User, die ihre Mail von
unterschiedlichen Mailservern beziehen. Ich haette das Ganze
jetzt gerne so eingerichtet, dass alle Mailprogramme lokal
arbeiten, d.h. ihre Mails in /var/spool/mail/<user> abholen.
Dann soll jedesmal, wenn eine Verbindung zum Internet
aufgebaut wird, das sendmail nachschauen, ob Mails zu
versenden sind. Also habe ich ein "sendmail -q" in
ip-up eingebaut.
Weiter soll natuerlich dabei auch gleich nach neuer Mail
geschaut werden, also gibs in ip-up fuer jeden User einen
Eintrag "su <user> -c fetchmail".

Nur leider (warum sollte ich sonst auch posten) funktioniert das
ganze nicht. Beim Senden soll sendmail natuerlich unterscheiden,
ob die Mail fuer einen lokalen User oder fuer ausserhalb bestimmt
ist. Das funktioniert sogar. Nur bei externer Mail traegt es in den
Absender die Adresse <user>@<hostname> ein. Nun kennt
mein Mailserver (hier rumms.uni-mannheim.de) natuerlich weder
meinen frei erfundenen Hostnamen noch den User und lehnt die
Mail natuerlich ab. Wo bring ich sendmail also bei, die
Adressen entsprechend umzusetzen?

Beim Empfangen klappt ebenfalls nix. Das fetchmail holt die
Mails zwar ab, aber dann schickt sie irgendwer ins Nirvana.
Will heissen, sie sind verschwunden, ich kann sie einfach nicht
finden. IMHO kann wohl sendmail nix mit den Mails anfangen, die
ihm das fetchmail uebergibt, also was ist zu tun?

Und dann habe ich noch ein drittes Problemchen, das aber eher
klein ist: zum Einwaehlen nutze ich den diald. Bei einem ping z.B.
funktioniert das auch praechtig. Bei einigen Programmen aber
baut der diald zwar ne Verbindung auf, das Programm selbst merkt
davon aber nix. Die idle-Verbindung wird dann irgendwann wieder
gekillt und viel spaeter dann laeuft das Programm in einen Timeout
und liefert eine Fehlermeldung der Art "Host nicht gefunden". Dies
laeuft z.B. bei Netscape und kmail beim Mails holen so.

Es waere schoen, wenn mir jemand von Euch helfen koennte.
Braucht ihr noch mehr Infos? Denn sagt mal Bescheid.

Gruss
        Mathias


Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

Dieses Archiv wurde generiert von hypermail 2.1.2 : 11. Mar 2002 CET