Re: Debian: sdc1 fehlt in /dev/ nach Upgrade auf Squeeze

Autor: Peter Mueller <peter.o.mueller_at_gmx.de>
Datum: Tue, 15 Feb 2011 20:53:24 +0100
Hallo,

On 15.02.2011, at 20:41, Markus Hochholdinger wrote:

> Hi,
> 
> Am 15.02.2011 um 19:44 Uhr schrieb Peter Mueller <peter.o.mueller_at_gmx.de>:
> [..]
>> danke für all die Antworten. Inzwischen läuft der Abgleich der beiden
>> Platten wieder. Da habe ich wohl nochmal Glück gehabt.
> 
> super, das freut mich zu hören.
> 
> Was hast Du nun genau gemacht um das Problem zu beheben?
> 

Ich bin deinem Vorschlag gefolgt:

Was ich nun machen würde (mir root-Rechten):
* Wenn Dir die Daten wichtig sind, Kopiere sdc mit dd irgendwo hin, z.B. auf
 eine andere Platte. (Wer weiß, vielleicht liege ich falsch und alle Daten
 waren auf sdc korrekt anstatt sdb1!)
* Entferne in der Konfiguration alles was auf die uuid
 bdedd91a:6dd172b3:bd1ac19b:fae98e89 verweist (sdc).
* "Reset" von sdc:
   mdadm --zero-superblock /dev/sdc # Superblock auf sdc löschen
-->   fdisk /dev/sdc #Partition neu erstellen, evtl. Neustart danach?  <--
   mdadm --zero-superblock /dev/sdc1 # Superblock auf sdc1 löschen
* md0 starten:
   mdadm --assemble /dev/md0 /dev/sdb1 # evtl. mit forcce nachhelfen!?
* RAID1-Rebuild durchführen:
   mdadm --add /dev/md0 /dev/sdc1


Den mit ---> gekennzeichneten Punkt habe ich nicht gemacht, stattdessen habe
ich die Partitionstabelle von sdb nach sdc kopiert.

> Weißt Du denn nun auch was die Ursache war (oder hast eine Vermutung)?
> 
> 

Nicht wirklich. Das Raid ist vor dem Update gelaufen. Ich vermute beim
Upgrade ist was kaputtgegangen.

Gruß,
Peter
-- 
UUGRN e.V. http://www.uugrn.org/
http://mailman.uugrn.org/mailman/listinfo/uugrn
Wiki: https://wiki.uugrn.org/UUGRN:Mailingliste
Archiv: http://lists.uugrn.org/
Empfangen am 15.02.2011

Dieses Archiv wurde generiert von hypermail 2.2.0 : 15.02.2011 CET