Re: Perl und Seriell

Autor: Alexander Dehoff <alexander_at_dehoff.ch>
Datum: Mon, 16 Jul 2007 20:09:05 +0200
Hallo Andreas,

Danke für die Antwort, klappt in diesem Fall aber leider nicht, da der
Stecker in die MSA ein TP Stecker ist, am anderen Ende (für den
"Client") aber ein serieller Stecker.

Noch jemand ne andere Idee?

Danke auch :)

Alexander

On Mon, Jul 16, 2007 at 04:52:28PM +0200, Andreas Krauß wrote:
> Hallo Alexander,
> 
> ich persönlich bin ja eigentlich ein Anhänger der "einfachen/alten" 
> Schnittstellen ... seriell/parallel ... mit USB ist da alles sooo 
> kompliziert geworden :-)
> 
> Die Antwort löst dein Problem nicht direkt, vielleicht hilft es ja aber 
> trotzden weiter ...
> 
> Bei seriellen Schnittstellen bin ich total von Seriell2Ethernet-Adapter 
> überzeugt !!! Angeschlossen, konfiguriert und mit netcat drauf zugreifen 
> .... keinerlei Probleme! Nutzen wir z.B. zum Auslesen von LKW-Waagen :-) 
> Da hat Ethernet noch den großen Vorteil der einfacheren 
> Verkabelung/Leitungslänge ... die Waage muß nicht mehr seriell an den PC 
> im Wiegehäuschen angeschlossen werden und wird direkt vom Server 
> angesprochen ... für uns gibts zur Zeit keine bessere Lösung!
> 
> Je nach deinem Einsatzzweck ... ich weiß nicht, ob da etwas 
> zeitkritisches Ausgelesen wird,  ist die Netzwerkgeschickte eventuell 
> vom Timing etwas problematisch .... dann gehts aber auf jedem Fall wenn 
> der Seriell2Ethernet-Adapter per Crossover-Kabel angeschlossen wird :-)
> 
> VG
> 
> Andreas
> 
> Alexander Dehoff schrieb:
> >Liste,
> >
> >bin mal wieder mit einem seltenen Problem befasst:
> >
> >Wir haben hier auf Arbeit ein MSA von HP, das nur Seriell ausgelesen
> >werden DARF!.
> >Habe daran angeschlossen einen VMWare ESX-Server und möchte u.a. "show
> >tech_support" absetzen und die Ergebnisse auslesen.
> >Die sinnigste Hilfe habe ich unter:
> >http://nntp.perl.org/group/perl.beginners/2005/037msg73220.html
> >bekommen. Habe die Geschwindigkeit und die Commandos entsprechend 
> >angepasst.
> >
> >Leider bekomme ich nur je gesendetem \n eine Zahl höher raus, sprich
> >wenn ich ein "\n" sende um den Prompt zu bekommen und mir den aktuellen
> >Inhalt ausgeben lasse bekomme ich als Wert 1, egal was ich absetze nach
> >jedem "\n" geht das ergebnis ein hoch.
> >
> >Schliesse ich aber z.B. ein Win-NB mit aktuellem putty (hat inzwischen
> >serielle Unterstützung) klappt das wunderbar, ist aber im Betrieb
> >unbrauchbar.
> >
> >dmesg | grep tty bringt:
> >ttyS0 at 0x03f8 (irq = 4) is a 16550A
> >ttyS1 at 0x02f8 (irq = 3) is a 16550A
> >
> >Habe mit stty die Inhalte ausgelesen und sieht soweit OK aus.
> >Das Ganze versuche ich nur auf ttyS0, da die Kiste hinten nur COM1 hat
> >(HP DL385, falls relevant).
> >
> >Bin mit meinem Latein ziemlich am Ende, hat jemand noch ne Idee?
> >
> >Achja, darf auch gerne als Shell-Script gehen, hauptsache ich kann den
> >"show tech_support" absetzen.
> >
> >Danke Euch schonmal
> >
> >Alexander
> >  

-- 
http://www.xing.com/go/invita/4418387
LPIC1: https://www.lpi.org/de/verify.html ID: LPI000034134 Code: 7vjprwrfud


-- 
http://mailman.uugrn.org/mailman/listinfo/uugrn


Empfangen am 16.07.2007

Dieses Archiv wurde generiert von hypermail 2.2.0 : 16.07.2007 CEST