Re: Prob mit NFS unter Kernel 2.6.3

Autor: Alexander Dehoff (alexander_at_dehoff.ch)
Datum: 11. Mar 2004


> On Thu, Mar 11, 2004 at 12:35:02PM +0100, alexander_at_dehoff.ch wrote:
> > Hi,
> >
> > ich hab mal wieder ein Prob:
> >
> > Ich habe den Kernel 2.6.3 von Hand kompiliert und habe vermutlich
> > irgendeine Option vergessen (ich hoffe, ich brauche nicht die .config
> > hier zu posten). Die Fehlermeldung bei "/etc/init.d/nfs-kernel-server
> > start" kommt:
> > Exporting directories for NFS kernel daemon...ws-schaff:/Medien: No
> > such device
> > done.
> >
> > die exports sieht wie folgt aus:
> > /Medien ws-schaff(rw)
> >
> > /Medien exisitert (ist ein Mountpoint), per Samba und bash kann ich
> > wunderbar drauf zugreifen.
> >
> > ps -ef | grep nfs bringt:
> > /usr/sbin/rpc.mountd --no-nfs-version 3
> >
> > Wenn ich trotzdem versuche vom Client aus das Verzeichnis zu mounten
> > kommt:
> > mount: 192.168.0.1:/Medien failed, reason given by server: Permission
> > denied
> >
> > Hat jemand ne Idee, woran es liegen könnte?
>
> Konkret weiss ich das jetzt aufgrund dieser Informationen noch nicht. Aber
> hast du vielleicht eine alte nfs-utils-Version installiert?
>
nfs-utils sind mit aptitude nicht zu finden, abgesehen davon, wenn ich den alten 2.4.18er Kernel boote läuft es, ich habe spasseshalber mal den nfs-kernel-server runter geschmissen, dafür den nfs-user-server installiert, der bringt mir zwar keine FM, die Clients können das ganze auch mounten, aber nicht darauf zugreifen. Anschliessend habe ich den alten nfs-kernel-server wieder installiert , worauf keine FM beim starten kam, die Clients kriegen aber immernoch dieselbe FM. Nach einem /etc/init.d/nfs-kernel-server restart kamen die alten FMs wieder.

Noch ne Idee?

Danke!

Alexander


Dieses Archiv wurde generiert von hypermail 2.1.7 : 11. Mar 2004 CET