Samba 3, Debian und Umlaute

Autor: Alexander Dehoff (Alexander.Dehoff_at_gmx.de)
Datum: 09. Mar 2004


Hallo,

ich habe hier Debian 3.0r1 stable mit Samba 3.0.1am laufen.

Das Problem: wenn ich unter Win ein File erstelle oder umbenenne, das
Sonderzeichen enthällt, bekomme ich das auch wunderbar angezeigt, aber auf der
Shell sehe ich nur Fragezeichen anstelle des äöü.

In der [Global] habe ich schon wild rum gespielt mit den verschiedensten
codepages. Zur Zeit sieht der Abschnitt so aus:

dos charset = CP1252
unix charset = ISO8859-1
display charset = ISO8859-1

ISO8859-1, da mir lsmod den als einzigen anzeigt (ich vermute dass er im
Standard-Kernel fest einkompiliert ist), ausserdem steht das in zig Newsgroups
drin, dazu habe ich die ASCII UTF8, UTF-8, 850, CP850, ISO8859-15 getestet, in
allen Variationen.

Ich habe auch schon versucht die Keymap entsprechend anzupassen (habe keine
Ahnung ob das etwas damit zu tun haben könnte, habs aber mit "install-keymap
/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz" eingerichtet und
neu gebootet), aber auf den Server komme ich nur per putty und da gehen auch
keine Sonderzeichen, öäü sind tot, ß entspricht der Pfeil hoch Taste, was
mir aber zoemlich egal ist, da ich auf der Konsole eh keine Sonderzeichen
brauche.

Hat jemand noch ne Idee?

Danke!!!

Alexander

-- 
+++ NEU bei GMX und erstmalig in Deutschland: TÜV-geprüfter Virenschutz +++
100% Virenerkennung nach Wildlist. Infos: http://www.gmx.net/virenschutz

Dieses Archiv wurde generiert von hypermail 2.1.7 : 09. Mar 2004 CET