Re: Ein etwas anderes LILO Problem

Autor: Christian Eichert (moga_at_multimedia.homelinux.org)
Datum: 26. Jan 2004


Ich habe zwei platten
auf der einen ist redhat auf der anderen ist debian

Frage:
WIE MUSS ICH DIE BEIDEN LILO configurieren damit ich von der einen
platte die andere booten kann.

jeweils :
[Redhat]
hda1 primär ext3 /boot
hda2 primär swap
hda3 primär ext3 /

und
[Debian]
hdb1 primär ext3 /boot
hdb2 primär swap
hdb3 primär ext3 /

das redhat lilo.conf sieht so aus:
==================================
prompt
timeout=60
vga=795

boot=/dev/hda

map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

 
 
                   default=Redhat

image=/boot/vmlinuz-2.4.20-27.9
         label=linux.bak
         read-only
         initrd=/boot/initrd-2.4.20-27.9.img
         append="hdd=ide-scsi root=LABEL=/"
 
 

image=/boot/vmlinuz-2.4.20-28.9
         label=Redhat
         append="hdd=ide-scsi root=LABEL=/"
         read-only
         initrd=/boot/initrd-2.4.20-28.9.img

das debian lilo.conf sieht so aus:
=================================
prompt
lba32

#boot=/dev/hda
root=/dev/hda3
 

install=/boot/boot-menu.b
map=/boot/map
 

delay=20
 

timeout=60
vga=794

default=Debian
 
 

image=/boot/vmlinuz
         label=Debian
         read-only
# restricted
# alias=1

                                                           \|/
         CE (o o)
------------------------------------------------------oOO--U--OOo--
  Christian Eichert
  e-mail moga_at_multimedia.homelinux.org .oooO
  www http://multimedia.homelinux.org ( ) Oooo.
------------------------------------------------------\ (----( )-
                                                        \_) ) /
                                                              (_/
"Be liberal in what you accept, and conservative in what you send."
  Jon Postel, August 6, 1943 - October 16, 1998


Dieses Archiv wurde generiert von hypermail 2.1.7 : 26. Jan 2004 CET