KDE/Debian Probleme

Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

Autor: Sascha Morr (sascha.morr_at_sturmkind.info)
Datum: 29. Jan 2003


Hallo ;-)

Ich wollte gerade KDE 3.1 auf mein Debian Woody System packen. Also habe
ich in meine _/etc/apt/sources.list_ folgende Zeile gepackt:

deb ftp://ftp.kde.org/pub/kde/stable/latest/Debian stable main

Danach ein _apt-get update_ und danach ein _apt-get dist-upgrade_ (wurde
mir auf der KDE-Liste anstatt eines _apt-get upgrade angeraten). Das
ging einwandfrei bis folgende Meldung kam:

Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libarts1_1.1.0-0woody4_i386.deb
 /var/cache/apt/archives/libartsc0_1.1.0-0woody4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Darauf habe ich es noch einmal mit _apt-get dist-upgrade_ versucht und
es kam folgendes:

root_at_sushi:/home/sturmkind> apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  kdelibs-bin: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is
installed kdelibs4: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is
installed kmidi: Depends: libartsc0 (>= 1.1.0) but it is not installed
  libarts1-audiofile: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is
installed libarts1-mpeglib: Depends: libarts1 (>= 1.1.0) but
1.0.5a-0woody1 is installed Depends: libartsc0 (>=
1.1.0) but it is not installed libkonq4: Depends: libarts1 (>= 1.1.0)
but 1.0.5a-0woody1 is installed E: Unmet dependencies. Try using -f.
root_at_sushi:/home/sturmkind>

Als ich dann versucht habe z. B. kdelibs4 mit _apt-get -f install
kdelibs4_ kam folgendes:

root_at_sushi:/home/sturmkind> apt-get -f install kdelibs4
Reading Package Lists... Done
Building Dependency Tree... Done
Sorry, kdelibs4 is already the newest version.
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  kdelibs-bin: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is to be
installed kdelibs4: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is
to be installed kmidi: Depends: libartsc0 (>= 1.1.0) but it is not
going to be installed libarts1-audiofile: Depends: libarts1 (>= 1.1.0)
but 1.0.5a-0woody1 is to be installed libarts1-mpeglib: Depends:
libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is to be installed
    Depends: libartsc0 (>= 1.1.0) but it is not going to be installed
libkonq4: Depends: libarts1 (>= 1.1.0) but 1.0.5a-0woody1 is to be
installed E: Unmet dependencies. Try 'apt-get -f install' with no
packages (or specify a solution). root_at_sushi:/home/sturmkind>

Dann habe ich es mit _apt-get -f dist-upgrade_ versucht und erhielt
folgende Ausgabe:

root_at_sushi:/home/sturmkind> apt-get -f dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
Calculating Upgrade... Done
The following NEW packages will be installed:
  libartsc0
1 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
77 packages not fully installed or removed.
Need to get 0B/889kB of archives. After unpacking 946kB will be used.
Do you want to continue? [Y/n]
(Lese Datenbank ... 51422 Dateien und Verzeichnisse sind derzeit
installiert.) Vorbereiten zum Ersetzen von libarts1 1.0.5a-0woody1
(durch .../libarts1_1.1.0-0 woody4_i386.deb) ...
Entpacke Ersatz-libarts1 ...
dpkg: Fehler beim Bearbeiten von
/var/cache/apt/archives/libarts1_1.1.0-0woody4_ i386.deb (--unpack):
 versuche »/usr/lib/libqtmcop.so.1.0.0« zu überschreiben, welches auch
in Paket libarts1-qt ist
dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe
unterbrochen (bro ken pipe))
Entpacke libartsc0 (aus .../libartsc0_1.1.0-0woody4_i386.deb) ...
dpkg: Fehler beim Bearbeiten von
/var/cache/apt/archives/libartsc0_1.1.0-0woody4_i386.deb (--unpack):
 versuche »/usr/lib/libartsc.so.0.0.0« zu überschreiben, welches auch in
Paket l ibarts1 ist
dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe
unterbrochen (bro ken pipe))
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libarts1_1.1.0-0woody4_i386.deb
 /var/cache/apt/archives/libartsc0_1.1.0-0woody4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root_at_sushi:/home/sturmkind>

Was könnte das nur sein? Ist wirklich zum Haareraufen ;-(

Grüße
Sascha


Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

Dieses Archiv wurde generiert von hypermail 2.1.4 : 29. Jan 2003 CET