AW: WinNT, Linux und LILO

Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

From: Wolfgang Grosch (grosch_at_nikocity.de)
Date: 02. Feb 2000


Hallo Namensvetter,

Linux ist auf hdb1 installiert, und somit sollte es unter den ersten 1024 Zylindern liegen.
Oder sehe ich das falsch und die 1024 Zylinder Beschränkung bezieht sich auf hda1, da
von dort gebootet wird??????

Jetzt eine ganz dumme Frage: Muss das /boot directory eine eigene Partition haben???
Wenn ja, dann ist das mein Fehler, da ich keine /boot-Partition angelegt habe, sondern
nur eine /root-, /swap-, /opt-, /usr-Partition, und Lilo ist auf /root installiert.

Trotzdem Danke für den Tip.

Grüsse Wolfgang

-----Ursprüngliche Nachricht-----
Von: Messingschlager, Wolfgang [SMTP:Wolfgang_Messingschlager_at_bmc.com]
Gesendet am: Mittwoch, 2. Februar 2000 18:46
An: 'grosch_at_nikocity.de'
Cc: 'uugrn_at_linuxbbs.org'
Betreff: RE: WinNT, Linux und LILO

Hallo Wolfgang,

kann es sein, dass das /boot directory nicht in den ersten 1024 Zylindern
liegt?

Dies ist eine notwendige Voraussetzung.

Mit freundlichen Grüßen

Wolfgang Messingschlager
System Specialist

-- 

Das Wort "WINDOWS" stammt aus einem alten Sioux-Dialekt und bedeutet: "Weisser Mann starrt durch Glasscheibe auf Sanduhr."

Für die einen ist es LINUX, für die anderen das sicherste Betriebssystem der Welt!

-----Original Message----- From: Wolfgang Grosch [mailto:grosch_at_nikocity.de] Sent: Montag, 31. Januar 2000 10:44 To: Unix User Group Rhein-Neckar e. V. (E-Mail) Subject: WinNT, Linux und LILO

Hallo Liste,

ich habe ein Problem mit LILO. Vorneweg meine PC-Konfiguration: P233MMX, IBM-HD 8,4GB (hda), WD 6,4GB (hdb), u.s.w. Installiert ist auf hda WinNT und auf hdb ist SuSE 6.3. LILO war auf root-Partition installiert und dann habe ich laut Anweisung vom SuSE-Handbuch den bootsek.lin auf eine Diskette erzeugt und in %root%-Verzeíchnis NT kopiert. Eintrag in NT-Boot-Manager. Sonst hat es keine Probleme gegeben, wenn SuSE auf hda installiert war. Jetzt, da SuSE auf hdb installiert ist, und ich mit dem NT-Boot-manager Linux starten möchte, bekomme ich folgende Fehlermeldung nach SuSE-Support:

"LI Die zweite Stufe von LILO wurde geladen, konnte aber nicht gestartet werden. Dies kann verursacht werden durch eine fehlerhafte Platten-Geometrie oder durch Verschieben von /boot/boot.b ohne Neuinstallation von LILO."

Da ich mit dieser Hilfe/ Erklärung leider nichts anfangen kann, (was ist bitte schön eine fehlerhafte Platten-Geometrie?? Ist das passiert, weil ich eine andere Platte habe??) habe ich LILO auf Diskette erzeugt, um mein Linux zu starten. So, meine erste Überlegung war, mir einen anderen Boot-Manager zu installieren. Leider musste ich feststellen, dass von den geläufigen keiner NTFS unterstützt. Weitere Überlegung war, dass ich NT runterschmeiss und in die 1. Partition DR DOS von Caldera installiere und dann wieder NT (Brauche ich nun mal und ist besser als Win 95). Dazu habe ich aber keine Lust, da ich NT schon x-mal installiert habe und es jetzt "gut" läuft. Dann könnte ich bspw. einen Boot-Manager auf die 1. Partition installiern, ohne auf den Boot-Manager von NT angewiesen zu sein. Eine weiter Überlegung wäre (ist mir mal wieder beim Aufwachen eingefallen), eine Wechselrahmen zu holen, und in den die IBM (hda) einbauen. Wenn ich die Platte dann vor dem Booten "abschliesse" müsste ich doch eigentlich von hdb starten können, wenn LILO in der Root-Partition installiert ist. Oder funktioniert das nicht, da hdb als Slave eingestellt ist?? So, das wars.

Lange Rede, kurzer Sinn, wer von Euch kann mir helfen?????? Vielen Dank schonmal im voraus.

Grüsse Wolfgang


Datumsansicht Baumansicht Betreffansicht Attachement-Sicht

Dieses Archiv wurde generiert von hypermail 2.1.2 : 11. Mar 2002 CET